Druchii.net
http://druchii.net/phpBB3/

After the migration. Report problems?
http://druchii.net/phpBB3/viewtopic.php?f=5&t=71944
Page 1 of 1

Author:  Calisson [ Sat Mar 02, 2013 9:01 pm ]
Post subject:  After the migration. Report problems?

Hi.
Daeron and Rork have fixed many problems that have been evidenced since the migration.
If you spot anything still requiring a fix, this thread is the place to report it.
Thank you for your participation to the improvement of D.net.

Author:  Brad [ Thu Mar 19, 2015 8:59 pm ]
Post subject:  Re: After the migration. Report problems?

Not sure if the migration caused it or not, but the "Mark Forum Read" button doesn't appear to be working properly. It seems like it works at first, but then when I come back the next day all the old topics are still there, listed as unread.

Author:  Lord Drakon [ Thu Mar 19, 2015 9:15 pm ]
Post subject:  Re: After the migration. Report problems?

Brad wrote:
Not sure if the migration caused it or not, but the "Mark Forum Read" button doesn't appear to be working properly. It seems like it works at first, but then when I come back the next day all the old topics are still there, listed as unread.


Same here

Author:  Daeron [ Fri Mar 20, 2015 8:42 am ]
Post subject:  Re: After the migration. Report problems?

While not related to the migration itself, it is indeed a technical issue that came up recently. Initially I thought it had to do with an update to Google Chrome, but I'll dig a little deeper.
You can clear the list by logging out and back in, but that only resets the list.

Just to make sure, though. Are you sure the problem has to do with "unread" messages? If I click "mark all forums read", and then "view unread posts", then it tells me there are no results.
However, if I click "view new posts" (which should give posts since last visit, read or not), then that list keeps growing.

Author:  Brad [ Fri Mar 20, 2015 9:22 am ]
Post subject:  Re: After the migration. Report problems?

I'm using Firefox, so it's definately not related to Chrome.

It may indeed be that I'm clicking "New" rather than "Unread" - as with all things done so many times for so many years, I'm not actually paying attention to exactly which link I click, it's all just muscle memory. But having said that, whatever I was doing always worked before, and now it isn't.

Author:  Daeron [ Fri Mar 20, 2015 10:38 am ]
Post subject:  Re: After the migration. Report problems?

FireFox had an update as well... Hm. But I wouldn't bet my money on it just yet.

The issue seems releated to session/cookie management, which is browser and server related. No settings changed on the server. Googling about, I find another forum with the same issue:
http://area51.phpbb.com/phpBB/viewtopic ... 81&t=46616
Which is suspicious to say the least.
Yet other phpBB3 servers don't have the same problem. (Like Ulthuan or something ;))

It could be related to a php version update on the server, which may have messed up a session management function of phpBB. Anyhow. I'll keep looking!

Author:  Daeron [ Fri Mar 20, 2015 10:45 am ]
Post subject:  Re: After the migration. Report problems?

I removed my own cookies to see if it would solve the problem. Now here's to waiting ;)

Author:  Brad [ Fri Mar 20, 2015 9:17 pm ]
Post subject:  Re: After the migration. Report problems?

This morning I remembered to force myself to click "Unread" and lo! it appears to be working as intended. "New" still show two pages of stuff that, well, isn't new at all.

Author:  Daeron [ Mon Mar 23, 2015 6:07 am ]
Post subject:  Re: After the migration. Report problems?

So after a bit of waiting, and testing ver various devices, the issue seems to return server-side. I'm going to check if there was an unexpected php upgrade or something that messed up the session management.

Author:  Thraundil [ Mon Mar 23, 2015 10:59 am ]
Post subject:  Re: After the migration. Report problems?

On top of the above: whenever I currently try to send a private message, the browser times out (Chrome).

Author:  Amboadine [ Mon Mar 23, 2015 12:38 pm ]
Post subject:  Re: After the migration. Report problems?

Thraundil wrote:
On top of the above: whenever I currently try to send a private message, the browser times out (Chrome).


I had the same issue today, however when the page refreshed the message was in the outbox. That was on IE though.

Author:  Daeron [ Mon Mar 23, 2015 2:54 pm ]
Post subject:  Re: After the migration. Report problems?

Aye, the issue is related. There is something notably wrong with the session management. It seems to be a bug that occurs on phpBB3, if I'm to believe their bug tracker... but they haven't been able to figure out what causes it. Well that's hopeful! ;)

I'm working on it.

Author:  Daeron [ Mon Mar 23, 2015 6:11 pm ]
Post subject:  Re: After the migration. Report problems?

The good news is that I've discovered where the system goes wrong. The bad news is... I don't know why. Not yet ;)
I can remedy it on a daily basis while looking for the cause.

Author:  Daeron [ Tue Mar 24, 2015 1:07 pm ]
Post subject:  Re: After the migration. Report problems?

I put in a small patch. It should help with the new posts, but not all issues are resolved yet.

Author:  Ming [ Tue Mar 24, 2015 1:31 pm ]
Post subject:  Re: After the migration. Report problems?

It definitely works! Kudos!

Author:  Lord Drakon [ Wed Mar 25, 2015 4:33 pm ]
Post subject:  Re: After the migration. Report problems?

Its fixed !

Author:  Daeron [ Wed Mar 25, 2015 4:39 pm ]
Post subject:  Re: After the migration. Report problems?

Thank you for reporting. Unfortunately, not all issues are resolved yet, but the new posts should update more frequently.

Page 1 of 1 All times are UTC
Powered by phpBB® Forum Software © phpBB Group
http://www.phpbb.com/